We made some changes to the environment and are monitoring the performance and response times.
Posted May 15, 2026 - 19:59 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2026 - 20:15 UTC
Investigating
We are currently investigating an intermittent performance issue affecting our Command Center. Some users may experience slower-than-usual page load times, particularly on certain pages. Our engineering team is actively working to identify the root cause and implement a resolution. We will continue to provide updates as we make progress.