Degraded Backup Performance

Incident Report for m2

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 07:02 UTC

Monitoring

The issue has been identified and resolved. We are continuing to actively monitor backups to ensure stability.
Posted Jan 30, 2026 - 05:08 UTC

Update

We are continuing to investigate this issue.
Posted Jan 29, 2026 - 01:15 UTC

Investigating

We are currently experiencing degraded backup performance. Our team is actively investigating the issue and working to restore full service as quickly as possible. We will continue to provide updates as we make progress. Thank you for your patience.
Posted Jan 29, 2026 - 01:14 UTC
This incident affected: File & Object (East US2, Canada Central).